Casa / Hosting / Vulnerabilidades Open Source

Vulnerabilidades Open Source

Existe varias formas de um site feito em Open Source ser hackeado, poderá ser através de fuga de password, estando a password comprometida, posteriormente com acesso ao seu serviço o envio de ficheiros maliciosos.

A mais viral será o uso de templates e plugins de sites não oficiais, ou seja, o uso de templates descarregados de sites maliciosos ao qual quando instala a template ou plugin e o mesmo já contem ficheiros maliciosos que posteriormente iram originar spam ou comprometer informação como passwords entre outros.

Este tipo de Malware reproduz-se automaticamente, ou seja, após ficar infectado, mesmo que proceda à eliminação do ficheiro infectado já deve existir uma copia desse mesmo ficheiro infectado em outra directoria escondida, posteriormente quando o sistema detectar nova copia o serviço será novamente suspenso.

A detecção deste tipo de Malware é difícil devido ao código por vezes se encontrar encriptado.

Existe outros métodos como por exemplo as vulnerabilidades no código de software antigo ao qual posteriormente através dessas vulnerabilidades conseguem infectar o site com Malware ou ter acesso ao mesmo.

Estas vulnerabilidades não se encontram no servidor/serviço de Alojamento mas sim no software em questão em que são os colaboradores que desenvolvem os software como por exemplo WordPress(www.wordpres.org) que lançam novas actualizações para corrigir esse tipo de vulnerabilidades, é recomendado proceder sempre ás actualizações dos softwares.

Além disso, verifique

servidor dedicados

Quando os servidores dedicados são a opção certa

Os servidores virtuais e outros conceitos mais técnicos do mundo online estão cada vez mais …

Distribuído por Amen Portugal
© Direitos Autorais 2022, Todos Os Direitos Reservados